You need to download the latest flash player version here!